use strict;
my $str = 'some containing string http://www.example.com/subfolder/name.pdf or /subfolder/name.pdf
<a href="/pdf/subdir/name.pdf">clickhere</a><a href="/pdf/subdir/name.pdf">2nd PDF</a>';
my $regex = qr@(?<!\w)(?:http://www\.example\.com)?/(\S+?)\.pdf\b@ip;
my $subst = '/wp-content/uploads/old/$1.pdf';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";