import re
regex = re.compile(r"(?<!\w)(?:http://www\.example\.com)?/(\S+?)\.pdf\b", flags=re.IGNORECASE)
test_str = ("some containing string http://www.example.com/subfolder/name.pdf or /subfolder/name.pdf\n\n"
"<a href=\"/pdf/subdir/name.pdf\">clickhere</a><a href=\"/pdf/subdir/name.pdf\">2nd PDF</a>")
subst = "/wp-content/uploads/old/$1.pdf"
result = regex.sub(subst, test_str)
if result:
print(result)