import Foundation
let pattern = #"(?<!\w)(?:http://www\.example\.com)?/(\S+?)\.pdf\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
some containing string http://www.example.com/subfolder/name.pdf or /subfolder/name.pdf
<a href="/pdf/subdir/name.pdf">clickhere</a><a href="/pdf/subdir/name.pdf">2nd PDF</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/wp-content/uploads/old/$1.pdf"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)