$re = '/^((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3})$/m';
$str = '1.2.3.4
.2.3.4
.
1.2
100.1.0.
100.3.4.5
-1
-1.2.3.4
den.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);