$re = '/(<img\b|(?!^)\G)[^>]*?\b(src|width|height)=(["\']?)([^>]*?)\3/';
$str = '<img src="myurl.jpg" width="12" height="32">
<img src="myurl.jpg" height="32" width="12">
<img src=\'myurl.jpg\' height=\'32\' width=\'12\'>
<link src="ttt"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);