#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3} ).+?(?=\1)"
Local $sString = "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,878 ERROR [6] text text text" & @CRLF & _
"[11:28:31] : [Step 5/5] line text" & @CRLF & _
"[11:28:31] : [Step 5/5] more line text here" & @CRLF & _
"[11:28:31] : [Step 5/5] more line text here" & @CRLF & _
"[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,959 WARN [6] Done" & @CRLF & _
"[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,961 WARN [6] Done" & @CRLF & _
"[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,962 WARN [6] Done" & @CRLF & _
"[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,966 WARN [6] Done" & @CRLF & _
"[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,967 WARN [6] Done" & @CRLF & _
"[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,968 WARN [6] Done" & @CRLF & _
"[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,969 WARN [6] Done"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")