import Foundation
let pattern = #"(?s)(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3} ).+?(?=\1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,878 ERROR [6] text text text
[11:28:31] : [Step 5/5] line text
[11:28:31] : [Step 5/5] more line text here
[11:28:31] : [Step 5/5] more line text here
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,959 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,961 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,962 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,966 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,967 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,968 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,969 WARN [6] Done
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)