#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[(.+)?\] (.+?) (S\d* )?- (\d+) \[(.+)\]"
Local $sString = "[HorribleSubs] Fate Kaleid Liner PRISMA ILYA - 01 [720p]" & @CRLF & _
"[HorribleSubs] Akame ga Kill! - 02 [720p].mkv" & @CRLF & _
"[HorribleSubs] Aldnoah Zero - 08 [720p]" & @CRLF & _
"[HorribleSubs] Deadman Wonderland - 02 [720p]" & @CRLF & _
"[HorribleSubs] Tokyo Ghoul Root A - 01 [720p]" & @CRLF & _
"[HorribleSubs] Sword Art Online II - 02 [1080p]" & @CRLF & _
"[HorribleSubs] Yahari Ore no Seishun Love Come wa Machigatteiru Zoku - 07 [720p].mkv" & @CRLF & _
"[HorribleSubs] Love Live! S2 - 02 [720p]" & @CRLF & _
"[HorribleSubs] Fairy Tail S2 - 02 [720p].mkv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")