// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[(.+)?\] (.+?) (S\d* )?- (\d+) \[(.+)\]").unwrap();
let string = "[HorribleSubs] Fate Kaleid Liner PRISMA ILYA - 01 [720p]
[HorribleSubs] Akame ga Kill! - 02 [720p].mkv
[HorribleSubs] Aldnoah Zero - 08 [720p]
[HorribleSubs] Deadman Wonderland - 02 [720p]
[HorribleSubs] Tokyo Ghoul Root A - 01 [720p]
[HorribleSubs] Sword Art Online II - 02 [1080p]
[HorribleSubs] Yahari Ore no Seishun Love Come wa Machigatteiru Zoku - 07 [720p].mkv
[HorribleSubs] Love Live! S2 - 02 [720p]
[HorribleSubs] Fairy Tail S2 - 02 [720p].mkv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}