$re = '/ayam|nasi/m';
$str = '#nasilemak sedap betul
Makan kena tunggu 1 jam baru sampai. #service slow
#jus mangga dia mengancam betul. sedap!
sambal #nasilemak dia power
kena datang awal
#beratur panjang. #ayamgoreng power
banyak pilihan #lauk
anda kena cuba #nasilemak ayam goreng dia
#nasilemak terbaik
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);