import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+?\\/([^\\/]+?(?=\\)).+)$";
final String string = "url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;\n"
+ "url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;\n"
+ "url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;";
final String subst = "ВАЛЕНОК$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}