re = /.+?\/([^\/]+?(?=\)).+)$/m
str = 'url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;
url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;
url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;'
subst = 'ВАЛЕНОК$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result