# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+?\/([^\/]+?\).+)$"
test_str = ("url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;\n"
"url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;\n"
"url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;")
subst = "ВАЛЕНОК$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.