const regex = /(\:\w+\:|\<[\/\\]?3|[\(\)\\\D|\*\$][\-\^]?[\:\;\=]|[\:\;\=B8][\-\^]?[3DOPp\@\$\*\\\)\(\/\|])(?=\s|[\!\.\?]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\:\\w+\\:|\\<[\\\/\\\\]?3|[\\(\\)\\\\\\D|\\*\\$][\\-\\^]?[\\:\\;\\=]|[\\:\\;\\=B8][\\-\\^]?[3DOPp\\@\\$\\*\\\\\\)\\(\\\/\\|])(?=\\s|[\\!\\.\\?]|$)', 'g')
const str = `:( Hello!
Howdy :)!
Are you there :P?
I'm fine :)
:p
:O
:3
:|
:/
:\\
:\$
:*
:@
:-(
:-)
:-P
:-p
:-O
:-3
:-|
:-/
:-\\
:-\$
:-*
:-@
:^(
:^)
:^P
:^p
:^O
:^3
:^|
:^/
:^\\
:^\$
:^*
:^@
):
(:
\$:
*:
)-:
(-:
\$-:
*-:
)^:
(^:
\$^:
*^:
<3
</3
<\\3
:smile:
:hug:
:pencil:
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}