const regex = /(?:\s*#.*\n)*(\w+)\s*=\s*((?:[^#=\n]+(?:\n|$))+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*#.*\\n)*(\\w+)\\s*=\\s*((?:[^#=\\n]+(?:\\n|$))+)', 'g')
const str = `tag = value
tag2 = value2
value continuation2
# comment for tag3
tag3 = value3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}