re = /(?:\s*#.*\n)*(\w+)\s*=\s*((?:[^#=\n]+(?:\n|$))+)/
str = 'tag = value
tag2 = value2
value continuation2
# comment for tag3
tag3 = value3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end