// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^((^\+44)|^(4{2})|(^0{2}4{2})|(^0)|)([123789])\d{8,9}$").unwrap();
let string = "+44123456789
+441234567890
+44123456789
+441234567890
+447921040642
+441234567890
+44123456789
+44123456789
+441234567890
+44123456789
441234567890
44123456789
441234567890
447921040642
441234567890
44123456789
44123456789
441234567890
07921040642
0123456789
01234567890
0123456789
01234567890
01932867083
00441234567
0845121212
0044123456789
00441234567890
0123456789
01234567890
0123456789
01234567890
01932867083
00441234567
0044123456789
00441234567890
0044123456789
00441234567890
08006444454
4451925858
01420383091
112222222
111111111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}