import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b004010H2[127][02379](?:A[12])?\\b";
final String string = "$str = \"this is the code 004010H222A1 the rest is irrelevant\";\n"
+ "$str = \"the random number is 004010H223A2 ** anything else is irrelevant\";\n"
+ "$str = \"the last lottery number 004010H220A1 ~~ the rest is irrelevant\";\n"
+ "$str = \"yet another random sentence 004010H279A1 the rest is irrelevant\";\n"
+ "$str = \"any sentence before what i want 004010H279A1 the rest is irrelevant\";\n"
+ "$str = \"last winning number 004010H217~~~\";\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}