const regex = /^(\w+): (.*)\n\1: /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+): (.*)\\n\\1: ', 'gm')
const str = `abc: bla1 bla1 bla1...
abc: bla2 bla2 bla2...
bcd: bla bla bla...
cde: bla bla bla...
ghk: bla1 bla1 bla1...
ghk: bla2 bla2 bla2...
lmn: bla bla bla...
xyz: bla bla bla...
`;
const subst = `\1: \2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);