# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w+): (.*)\n\1: "
test_str = ("abc: bla1 bla1 bla1...\n"
"abc: bla2 bla2 bla2...\n"
"bcd: bla bla bla...\n"
"cde: bla bla bla...\n"
"ghk: bla1 bla1 bla1...\n"
"ghk: bla2 bla2 bla2...\n"
"lmn: bla bla bla...\n"
"xyz: bla bla bla...\n")
subst = "\\1: \\2 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.