$re = '/^(\w+): (.*)\n((?:(?!\1).*\n)+)\1: (.*\n)/m';
$str = 'abc: bla1 bla1 bla1...
cde: bla bla bla...
ghk: bla1 bla1 bla1...
lmn: bla bla bla...
abc: bla2 bla2 bla2...
bcd: bla bla bla...
ghk: bla2 bla2 bla2...
xyz: bla bla bla...';
$subst = "\1: \2 \4\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;