import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(012)|(123)|(234)|(345)|(456)|(567)|(678)|(789)";
final String string = "123\n"
+ "9876456000\n"
+ "123456789\n"
+ "91370\n\n"
+ "111\n"
+ "415263\n"
+ "xyz123xyz";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}