$re = '/\{\{.*?(\{\{.*?\}\})*\}\}/m';
$str = 'lorem {{text {{text2}} *7yh#!$@* }} lorem {{text {{text2}} *7yh#!$@* }} lorem';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);