$re = '/\b(?:([123456789])(?![123456789]*\1))+\b/m';
$str = '123456788
123456789
123456790
123456798
123456799
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);