$re = '/(?<name>\w+)\((?<content>(.*|(\R)).*)\)/m';
$str = 'sin0+sin90+sin(90+sin(sin(sin())))+sin(0)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);