#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<span><img (id=\"([^"]*)\").*><\/span>"
Local $sString = "<section>" & @CRLF & _
"<span><img id="id1" src="src" alt="alt"></span>" & @CRLF & _
"<span><img id="id2" src="src" alt="alt"></span>" & @CRLF & _
"</section>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")