using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span><img (id=\""([^""]*)\"").*><\/span>";
string input = @"<section>
<span><img id=""id1"" src=""src"" alt=""alt""></span>
<span><img id=""id2"" src=""src"" alt=""alt""></span>
</section>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}