const regex = /<span><img (id=\"([^"]*)\").*><\/span>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span><img (id=\\"([^"]*)\\").*><\\\/span>', '')
const str = `<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}