// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<span><img (id=\"([^"]*)\").*><\/span>"#).unwrap();
let string = "<section>
<span><img id=\"id1\" src=\"src\" alt=\"alt\"></span>
<span><img id=\"id2\" src=\"src\" alt=\"alt\"></span>
</section>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}