import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "test(?!(?:(?!<_strong>).)*<_/strong>)";
final String string = "This is a test, and test word appears two times\n\n"
+ "This is a test, and <_strong>test word<_/strong> appears two times";
final String subst = "<_strong>$0<_/strong>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}