$re = '/(?=^.{1,254}$)(^(?>(?!\d+\.)[a-zA-Z0-9_\-]{1,63}\.?)+(?:[a-zA-Z]{2,})$)/m';
$str = 'Match:
host.domain.com
_host.domain.com
1host-2._ldap.domain.com
Non-Matches:
33.domain.com
host..com
this_really_long._fully_qualified_domain_name._contains_257_characters_w
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);