import Foundation
let pattern = #"^(.*?),\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"software.cisco.com , Added by IT, ZZ 6584"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$1\n#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)