import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B#+([a-z]\\w*(?!#)\\b)";
final String string = "Hello #world\n"
+ "#lol #sorryNotSorry #heya #coolbeans\n"
+ "# # # #\n"
+ "this is an in#line hash\n"
+ "too ##many tags\n"
+ "invalid chars #$? #;wha\n\n"
+ "#blue#red#yellow#green";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}