$re = '/\B#+([a-z]\w*(?!#)\b)/i';
$str = 'Hello #world
#lol #sorryNotSorry #heya #coolbeans
# # # #
this is an in#line hash
too ##many tags
invalid chars #$? #;wha
#blue#red#yellow#green';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);