re = /\B#+([a-z]\w*(?!#)\b)/i
str = 'Hello #world
#lol #sorryNotSorry #heya #coolbeans
# # # #
this is an in#line hash
too ##many tags
invalid chars #$? #;wha
#blue#red#yellow#green'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end