use strict;
my $str = '1a1.1a1af';
my $regex = qr/\d/p;
my $subst = '[/\\d/]';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";