re = /^(http|https?:\/\/(?:www\.|(?!www))[^\s\.]+\.[^\s]{2,3}|www\.[^\s]+\.[^\s]{2,3})$/
str = 'http://www.abc.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end