#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<iframe [^>]*?src=\"https?:\/\/(?:www\.)?youtu(?:be)?\.(?:com|be)\/(?:embed|watch)\/([^\?]*?)\?[^>]*?>\s*<\/iframe>"
Local $sString = "<iframe id="ytplayer" class="EmbeddedVideo" type="text/html" width="640" height="390" src="https://youtube.com/embed/NOLILBSJbrs?html5=1&fs=1" frameborder="0" allowfullscreen webkitallowfullscreen /></iframe>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")