const regex = new RegExp('([a-zA-Z]+\\://)?([a-zA-Z0-9\\-\\.]*\\.+[a-zA-Z]*)(:(6553[0-5]|655[0-2]\\d|65[0-4]\\d{2}|6[0-4]\\d{3}|5\\d{4}|[0-9]\\d{0,3}))?(/([a-zA-Z0-9\\-\\._\\?\\,\\\\'/\\\\\\+&%\\$#\\=~]*)[^\\.\\,\\)\\(\\s]?)?', 'g')
const str = `mail.google.com
google.it
www.mega.co/
http://www.google.it
mail.google.uk/login/auth.html
ftp://docs.python.org:54/login/
google.com:65535
python.info:65536`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}