// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Redirect\h+301\h+(\S+)\h+(\S+)").unwrap();
let string = "Redirect 301 /comment/375 http://site.com/posts/c0a323fc07
Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d
";
let substitution = "rewrite ^$1/?$ $2 permanent;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}