package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(((((0[1-9])|(1\d)|(2[0-8]))\/((0[1-9])|(1[0-2])))|((31\/((0[13578])|(1[02])))|((29|30)\/((0[1,3-9])|(1[0-2])))))\/(\d{4}))|((29\/02\/(\d{2})(([02468][048])|([13579][26]))))$`)
var str = `29/02/2016
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}