#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "=[\\a-zA-Z\{\}\[\]\-$%!=]{4,}"
Local $sString = "=2isjTsONZb!UrkVmsostBb}-KRL%R$E\\fQ{m$0lTVuwN!qFFkh0f$v]]wIir]vIY$SLUXJyyi-GFlJhohxgfH}=="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")