$re = '/=[\\\\a-zA-Z\{\}\[\]\-$%!=]{4,}/';
$str = '=2isjTsONZb!UrkVmsostBb}-KRL%R$E\\\\fQ{m$0lTVuwN!qFFkh0f$v]]wIir]vIY$SLUXJyyi-GFlJhohxgfH}==';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);