re = /=[\\a-zA-Z\{\}\[\]\-$%!=]{4,}/
str = '=2isjTsONZb!UrkVmsostBb}-KRL%R$E\\\\fQ{m$0lTVuwN!qFFkh0f$v]]wIir]vIY$SLUXJyyi-GFlJhohxgfH}=='
# Print the match result
str.match(re) do |match|
puts match.to_s
end