import Foundation
let pattern = #"=[\\a-zA-Z\{\}\[\]\-$%!=]{4,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"=2isjTsONZb!UrkVmsostBb}-KRL%R$E\\fQ{m$0lTVuwN!qFFkh0f$v]]wIir]vIY$SLUXJyyi-GFlJhohxgfH}=="#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}