use strict;
my $str = 'Öý salgysy: Aşgabat şäheri, Bekrewe, Şkolnaýa köçesi, jaý 5 (ýazgyda: Aşgabat şäheri, Büzmeýin etraby, Zemlestroitelnaýa köçesi, jaý 9)
Tel: +99365 70-59-03 ';
my $regex = qr/(?!\+9936[0-9][\s-]*|86[0-9])\d{2}[\s-]\d{2}[\s-]\d{2}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";