# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
# Keys are pretty much "any text before the '=' symbol"
(?P<key>[^=]+)
# Match the '=' symbol
=
(?P<value>
# Lazy match
.*?
# Look-ahead (don't move the "regex cursor", just "peek forward")
(?=
# Match a '_' that has no other '_' between it and the '=' character, or...
_(?=[^_=\n]+=)
|
# ... or the end of the line
$
)
)
# Actually "consume" the '_' character if it exists (or just match the end-of-line)
(?:_|$)
"""
test_str = ("str=string_number=12345_device=phone_color=blue\n"
"color=aqua_marine_name=matt_number=123_456_879_lastname=blahblah")
subst = "\\1 = \\2\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.