$re = '/^[\x{0600}-\x{06FF}\s]+$/u';
$str = 'عمر انی';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);