using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z\u00C0-\u00ff]{2,}(?: [a-zA-Z\u00C0-\u00ff]+){2,20}$";
string input = @"asd
asd
asd asd
asd asd asd
asd asd2 asd
asd2 asd asd
asd asd asd2
asd asd asd asd asd asd
asd asd asd asd asd asd asd asd asd asd asd asd
asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd
joao da silva
josé da silva
josé joão da silva
josé joão josé
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}