using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S)\b((?:S\d+)?EP?\d+\b)";
string substitution = @"$1 $2";
string input = @"克隆人战争S01E02 2008.720p-CMCT";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}